Does the app run on all tablets and laptops?

Vibrant Communities can run on most tablet and iPads, but some very old ones might struggle. Want to know more detail then read on.

For Android, the minimum requirement is Android 5 (Lollipop).


For iOS/iPadOS, the minimum is version 10.0.


For the best performance on the web we recommend that you use Chrome, but it will work in Safari, Firefox and others.


Remember, you'll also need 50+ megabytes of free storage space for the iOS app, and 30+ megabytes for the Android version.